
Excel 2013: Business Spreadsheets

Intermediate Excel Objectives
In this lesson, you will learn how to: 
1. Practice modifying cell contents and formats.
2. Use the Paste Special options.
3. CONCATENATE (combine) data with a formula.
4. Modify and format TEXT with formulas.
5. Use DATE and TIME formulas.
6. Use FINANCIAL formulas to calculate a payment.

This Little Piggy Goes to Market
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1. Readings
Read Lesson 2 in your Intermediate Excel 
Guide, page 51-81.

Project
Use formulas to format and modify TEXT, DATE, 
and TIME. Use FINANCIAL formulas to calculate a 
car payment.

Downloads
Legs Eggs Pigs 2013.xlsx
Counting Chickens 2013.xlsx
Brown Bag Sales Data 2013.xlsx

2. Practice
There is no Practice Activity for this lesson.

3. Assessment
Review the Test Yourself questions on page 
82.

Menu Maps
This lesson introduces the Formulas Ribbon.
1. Formulas -> Function Library->Text ->Concatenate, page 62
2. Formulas -> Function Library->Text ->UPPER, page 65
3. Formulas -> Function Library->Text ->SUBSTITUTE, page 67
4. Formulas->Function Library->Date & Time->MONTH, page 69
5. Formulas->Function Library->Date & Time->NETWORKDAYS, page 71
6. Formulas->Function Library->Financial->PMT, page 79

Formulas

Lesson 2: Little Piggy Goes to Market
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Start Microsoft Excel. 
When the Welcome screen 
appears, open a new, blank 
workbook. 

What Do You See from the 
top of the screen? 

Is there a Home Ribbon? 
And the Insert, Page 
Layout, Formulas, Data. 
Review and View Ribbons 
as well? Yes. 

Then you are ready to go. 

Formulas
In the previous lesson, the focus was on naming the cells that are included in a formula. We looked at the difference between Relative and 
Absolute Cell References. This lesson will use formulas to calculate, compare and format Text. We will also use formulas to summarize the data. 
I know, I know: the mere thought of formulas sends folks out the door. I believe that math is taught very poorly and that most people do NOT have 
a good understanding of the rules and options. This lesson will include a discussion of the math as well as what the spreadsheet software can do.
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Exam 77-420 Microsoft Excel 2013 
2. Create Cells and Ranges 
2.1 Insert Data In Cells and Ranges: Copy and Paste Data

Before You Begin 
This discussion begins by creating a sample 
spreadsheet that combines all of the dates and 
product sales forecast from three different 
spreadsheets. This lesson introduces a common 
copy/paste error, and methods for correcting it.

1. Try it: Open a Sample Spreadsheet
Open the spreadsheet you created in the previous 
lesson Legs Eggs Pigs 2013.xlsx
Go to the Pigs spreadsheet.
Select Row 5 through Row 28. 
(Do not include the Total in Row 29.)
Go to Home->Clipboard->Copy.

Go to a new spreadsheet.
Select Cell A1. 
Go to Home->Clipboard->Paste.
Keep going...!

Memo to Self: You can download and open the 
sample file or continue with the "Legs Eggs and 
Pigs" spreadsheet from the previous lesson.

There may be a yellow security banner at the top of 
the spreadsheet. Click ENABLE so you can work on 
this lesson, please. . 

Home->Clipboard->Copy
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Exam 77-420 Microsoft Excel 2013 
2. Create Cells and Ranges 
2.1 Insert Data In Cells and Ranges: Copy and Paste Data (Paste Errors)

Paste Between Worksheets
What Do You See? When you copy and paste 
data into a new spreadsheet, you may see many 
error messages. That's Excel's way of asking, 
"Where's the data?"

2. Try This: Review the #REF Errors
Click on any cell that says #REF!
You will see that the formulas are still there. This 
example shows: D3=D2+$B$3.

When you paste formulas into a new 
spreadsheet, the cell references may become 
meaningless. In this example, there is no 
Reference Cell, $B$3, so there is nowhere to 
look up the quantity.

3. Try This: Review the #VALUE! Errors
Click on any cell that says #VALUE!
You will see that the formulas are still there. This 
example shows: E4=C4+D4.

In this example C4 has Text, not Numbers. How 
do you multiply Text times Numbers? Hence, the 
error #value!

Keep going, please...

Home->Clipboard->Paste
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Exam 77-427 Microsoft Excel 2013 EXPERT
1. Manage and Share Workbooks 
1.3   Manage Workbook Changes: Identify Errors

Paste Errors
4. What Else Do You See? Look next to 
the #REF! message:  There is an 
exclamation point that flags the error. This 
error has been identified as an Invalid Cell 
Reference.

The Error options include:
Help on this error
Trace Error
Ignore Error
Edit in the Formula Bar
Error Checking Options

This #REF! error comes from pasting data 
from one spreadsheet to another, but the 
new spreadsheet does not include all of 
the Cells that the formulas reference. 

Keep going... 

Home->Clipboard->Paste
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Exam 77-420 Microsoft Excel 2013 
2. Create Cells and Ranges 
2.1 Insert Data In Cells and Ranges: Copy and Paste Data (Paste Special)

Paste Special Options
There is another method of pasting the Values, 
without the formulas.

Before You Begin: Delete the data that you just 
pasted. We are going to start over.

5. Try it: Paste Special
Go to the Pigs spreadsheet.
Select Row 5 through Row 28. 
(Do not include the Total in Row 29.)
Go to Home->Clipboard->Copy.

Go to a new spreadsheet, Sheet 2.
Select Cell A1. 
Go to Home->Clipboard->Paste.
Click on Paste Special.

What Do You See? There are four rows of 
 Paste Options. You can choose whether to 
keep the formatting, formulas, or values.

What Else Do You See? The Other Paste 
Options include Paste Link, so you can link the 
data from one workbook or spreadsheet to 
another and synchronize the data.
Keep going, there's more. ;-)

Home->Clipboard->Paste ->Paste Special 
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Exam 77-420 Microsoft Excel 2013 
2. Create Cells and Ranges 
2.1 Insert Data In Cells and Ranges: Copy and Paste Data (Paste Special)

Paste Special
What Do You See? Paste Special lets 
you choose what you want to paste. The 
default options include: All (everything), 
Formulas, Values, Formats, Comments, or 
Validation, only. 

Options to Remove Formatting
Paste Special can get rid of Formats, 
Themes, Borders or blanks you may have 
copied from the original sheet. 

Operation Options 
You can select the operation you want to 
paste: Add, Subtract, Multiply, Divide, or 
None.

6. OK, Paste Something
Select: Values and number formats.
Click OK. The Rows of data will be pasted. 
There should be no errors. 

Keep going...

Home->Clipboard->Paste ->Paste Special ->Values and Number Formats

The Computer Mama sez:
This can save you a lot of time!
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Exam 77-420 Microsoft Excel 2013 
2. Create Cells and Ranges 
2.1 Insert Data In Cells and Ranges: Copy and Paste Data (Paste Special)

Home->Clipboard-> Paste ->Paste Special ->Values 

Paste Special: Values
7. Try it: Paste the Sample Data
Go to the Eggs spreadsheet.
Select Row 2 through Row 24. 
(Do not include the Total in Row 25.)
Go to Home->Clipboard->Copy.
Go to the new spreadsheet, Sheet 2.
Select Cell A25. Go to Home->Clipboard->Paste-> 
Paste Special->Values and number formats.

Go to the Legs spreadsheet.
Select Row 2 through Row 24. 
Go to Home->Clipboard->Copy.
Go to the new spreadsheet, Sheet 2.
Select Cell A48. Go to Home->Clipboard->Paste-> 
Paste Special->Values and number formats.

Try This, Too: Rename the spreadsheet
Double-click the tab for this spreadsheet. Type: 
Original Data for TEXT Formulas.

8. Try This: Save the Spreadsheet
Go to File->Save.
Go to your Documents folder, if you wish.
Type the Name: Counting Chickens 2013.
Click on SAVE.
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File->Open

Format TEXT with Formulas
The next lesson demonstrates the TEXT 
functions. Each example creates a Cell 
Reference, and uses Arguments to create 
the formulas. 

The TEXT functions include:
CONCATENATE (combining fields)
UPPER/LOWER
SUBSTITUTE

1. Before You Begin: You can continue with 
the spreadsheet we have been working on or 
open the sample file if you wish: 
Counting Chickens 2013.xlsx

There should be a spreadsheet called Original 
Data for TEXT Formulas.

Keep going, please... 
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Exam 77-420 Microsoft Excel 2013 
1. Create and Manage Worksheets and Workbooks 
1.1 Create Worksheets and Workbooks: Copy and Move Worksheets

Text Formulas
Text as well as numbers can be edited by 
formulas. One useful Text function 
combines the data from several cells.

This function also has a cool name: 
Concatenate.

2. Try This: Make a Copy
Select the Original Data sheet.
Right click and make a Copy.
Name the new sheet: Text Functions.

And Try This: Add a Label
Select Cell F1.
Type: Product Revenue

Keep going....
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Exam 77-420 Microsoft Excel 2013 
4. Apply Formulas and Functions 
4.4 Format and Modify Text with Functions: CONCATENATE

Formulas -> Function Library-> Text ->Concatenate

Text Function: Concatenate
3. Try It: Concatenate the Text
Select Cell F2.
Go to Formulas->Function Library-> Text.
Click on: Concatenate.

Keep going...
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Text Formula Options
This formula combines two cells: B2, the 
name of the Product, with E2, the calculated 
revenue.

4. Try It: Edit the Text Function
Start by entering the cell references.

Edit Text1: B2
Edit Text2: D2

Click OK to CLOSE the Function Arguments. 

What Do You See? The formula is
=CONCATENATE(B2,D2)

This TEXT formula did, indeed, combine the 
fields. However, this result needs some 
improvements. 

Keep going...

Exam 77-420 Microsoft Excel 2013 
4. Apply Formulas and Functions 
4.4 Format and Modify Text with Functions: CONCATENATE

Formulas -> Function Library-> Text ->Concatenate
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Exam 77-420 Microsoft Excel 2013 
4. Apply Formulas and Functions 
4.4 Format and Modify Text with Functions: CONCATENATE

Additional Text Fields
If you add additional Text fields, you can include 
labels and punctuation if you wish.

5. Try This: Use Additional Text Fields
Select Cell F2 and delete the formula.
Select Cell F2, again.
Go to Formulas -> Function Library-> Text.
Click on Concatenate.
Edit Text1: "Daily Sales for "
Edit Text2: B2
Edit Text 3: ": "
Edit Text 4: D2
Click OK. 

Try This, Too: AutoFill the Formula
Select Cell F2.
AutoFill Cell F2 to the bottom of Column F.

What Do You See? Does your formula include the 
additional Text fields in the Concatenation?

Memo to Self: Whatever you type between the 
quotes will be displayed as text between the 
Concatenated Cells. If you need a space between 
the ": " colon and the number, then add a space to 
Text3 between the quotes.

Formulas -> Function Library-> Text ->Concatenate
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TEXT Functions: UPPER 
Look at the text in any spreadsheet. The data 
entry may not be consistent. Some people never 
use capital letters, and some folks make every 
word begin with a capital letter. 

You can create a formula that formats the Text: 
UPPER, LOWER, PROPER.

1. Try It: Add a Label
Go to the Text Functions spreadsheet.
Select Cell G1.
Type the label: UPPER

2. Try It: Use the UPPER Text Function
Select Cell G2.
Go to Formulas->Function Library-> Text.
Click on UPPER.

Keep going, please.

Exam 77-420 Microsoft Excel 2013 
4. Apply Formulas and Functions 
4.4 Format and Modify Text with Functions: UPPER

Formulas -> Function Library-> Text ->UPPER
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Exam 77-420 Microsoft Excel 2013 
4. Apply Formulas and Functions 
4.4 Format and Modify Text with Functions: UPPER

UPPER Text Arguments
3. Try This: Edit the Function Arguments
Edit the Text:B2. 

You should see a preview of the data in all 
capital letters, "PIGS". 
Click OK.

Try This, Too: AutoFill the Formula
Use the AutoFill handle to fill down this formula 
in Column G.

Memo to Self: The LOWER text function 
converts the text to all lowercase letters. 

The PROPER Text function begins each word 
with a capital letter.

Formulas -> Function Library-> Text ->UPPER
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Exam 77-420 Microsoft Excel 2013 
4. Apply Formulas and Functions 
4.4 Format and Modify Text with Functions: SUBSTITUTE

Text Functions: SUBSTITUTE 
The Substitute Text function can find and edit 
specific words or phrases. 

For example, you can compare the formula in 
Column F and Substitute "New Product Sales" for 
"Daily Sales."

1. Try This: Add a Label
Go to the Text Functions sheet.
Select Cell H1.
Type the following label: Substitute

2. Try This, Too: Substitute the Text 
Select Cell H2.
Go to Formulas->Function Library-> Text.
Click on: SUBSTITUTE.

Keep going...

Formulas -> Function Library-> Text ->SUBSTITUTE

Comma Training Page 67

Intermediate Microsoft Excel 2013   Page 67 of 245



Exam 77-420 Microsoft Excel 2013 
4. Apply Formulas and Functions 
4.4 Format and Modify Text with Functions: SUBSTITUTE

SUBSTITUTE Arguments
3. Try This: Enter the Arguments
Text: F2

Old_text: "Daily Sales"
Microsoft Excel will compare the text in your 
cell, F2. and determine if your data matches 
this Old_text.

New_text: "New Product Sales for"
This is the text that Microsoft Excel will 
substitute when it finds a word or phrase that 
matches.

You should see a preview of the data to the 
right of the Argument.

Click OK. 

Try This, Too: AutoFill the Formula
Use the AutoFill handle to fill down this 
formula in Column H.

Formulas -> Function Library-> Text ->SUBSTITUTE
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Exam 77-427 Microsoft Excel 2013 EXPERT
3. Create Advanced Formulas 
3.3  Apply Advanced Date and Time Functions: Use Functions to Serialize Dates and Times (Month)

Formulas->Function Library-> Date & Time->MONTH

Date Functions: MONTH
Businesses are "date driven." Bills need to be paid 
on time. The DATE functions can be used to format 
as well as calculate. 

Before You Begin: Make a Copy
Select the Original Data sheet.
Right click and make a Copy.
Name the new sheet: Date Functions.

1. Try This: Add a Label
Go to the Date Functions sheet.
Select Cell F1.
Type the following label: Date: Month

2. Try This, Too: Use a Date Function 
Select Cell F2.
Go to Formulas->Function Library-> Date & Time.
Click on: MONTH.

Keep going...
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Exam 77-427 Microsoft Excel 2013 EXPERT
3. Create Advanced Formulas 
3.3  Apply Advanced Date and Time Functions: Use Functions to Serialize Dates and Times (Month)

Formulas->Function Library-> Date & Time->MONTH

The MONTH Arguments
The purpose of the MONTH function is to read 
the date, figure out which month it is, and 
return a number for the month. In this 
example, the date is the Column A.

3. Try it: Edit the Serial_Number
Edit the Serial_Number: A2. 

You should see a preview of the data to the 
right of the Arguments.
Click OK.

4. Try This, Too: AutoFill the Formula
Use the AutoFill handle to fill down this 
formula in Column F. 

July is the 7th month in the year, as shown.

OK, that's an example of the MONTH function. 
Excel can also use Date functions with days.
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Exam 77-427 Microsoft Excel 2013 EXPERT
3. Create Advanced Formulas 
3.3  Apply Advanced Date and Time Functions: Use Functions to Serialize Dates and Times 
(NETWORKDAYS)

Formulas->Function Library-> Date & Time->Date

Calculating the Date
Many businesses need to calculate the difference between 
the current date and the date on the transaction. Microsoft 
Excel has several functions for working with Dates. 

Let's consider Date, Today, and Now. Today() and Now() 
both enter the date. The Today() function updates 
automatically to show the current the current date and time. 
The Now() function does not update automatically. These 
two functions do not have any Arguments. Date lets you 
enter the Arguments for Year, Month and Day. 

1. Before Your Begin: Make a Reference Date
Select Cell G1 and type: Reference Date
Select Cell G2.
Go to Formulas->Function Library->Date & Time->Date.
Enter the Function Arguments:
Year: 2013
Month: 8
Day:1
Click OK to close the Function Arguments. 

Do This, Too: Copy and Paste Cell G2 to G70
(all of the Rows in this example) Keep going...

Memo to Self: Columns C, D and E are hidden in this 
lesson so that you can see the date in Column A and the 
Reference Date in Column G. 
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Exam 77-427 Microsoft Excel 2013 EXPERT
3. Create Advanced Formulas 
3.3  Apply Advanced Date and Time Functions: Use Functions to Serialize Dates and Times 
(NETWORKDAYS)

Formulas->Functtion Library-> Date & Time->NETWORKDAYS

Date Functions: NETWORKDAYS
The NETWORKDAYS Function will calculate the 
number of work days (Monday through Friday) from the 
Reference Date in Column G to the Date in Column A.

2 Try This: Add a Label
We are still on the Date Functions sheet.
Select Cell H1.
Type the following label: Net Work Days

3. Try This, Too: Use a Date Function 
Select Cell H2.
Go to Formulas->Function Library-> Date & Time.
Click on: NETWORKDAYS.

Keep going...
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Exam 77-427 Microsoft Excel 2013 EXPERT
3. Create Advanced Formulas 
3.3  Apply Advanced Date and Time Functions: Use Functions to Serialize Dates and Times 
(NETWORKDAYS)

Formulas->Function Library-> Date & Time->NETWORKDAYS

NETWORKDAYS Arguments
4. Try it: Edit the NETWORKDAYS
Edit the Start_Date: A2. 
Edit the End_Date:G2

You should see a preview of the data to the right 
of the Arguments.
Click OK.

5. Try This, Too: AutoFill the Formula
Use the AutoFill handle to fill down this formula 
in Column H.

Memo to Self: The date that is displayed in the 
Preview is a SERIAL NUMBER. After you edit 
the Arguments, the work days will be displayed 
as a whole number.
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Exam 77-427 Microsoft Excel 2013 EXPERT
3. Create Advanced Formulas 
3.3  Apply Advanced Date and Time Functions: Calculate Duration

Home->Number->Number Format->Time

Time Functions
How many hours or minutes are there between 
the Start Time and the End Time? Here are 
the steps to figure it out.

1. Before You Begin: Enter the Data
Select Cell J1 and type: Start Time.
Select Cell K1 and type: End Time.
Select Cell L1 and type: Duration.
Format Cells J1, K1 and L1 BOLD.

Select Columns J and K.
Go to Home->Number->Number Format.
Select the Time format.
Select Cell J2 and type: 8:30 AM
Select Cell K2 and type: 5:00 PM

2. Copy the Data
Copy and Paste Cell J2 to J70 
Copy and Paste Cell K2 to K70 
(all of the Rows in this example) 

What Do You See?
The Cells in Column J have: 8:30:00 AM.
The Cells in Column K have: 5:00:00 PM
OK, keep going...
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Exam 77-427 Microsoft Excel 2013 EXPERT
3. Create Advanced Formulas 
3.3  Apply Advanced Date and Time Functions: Calculate Duration

Home->Number->Time

Calculate the Duration
Duration is the number of hours, minutes and 
seconds from the Start Time to the End Time.

3. Try it: Calculate the Duration 
Select Cell L2 and type:=K2-J2,
Where K2 is the End Time and J2 is the Start 
Time.

Please AutoFill this formula from L2:L70.
(all of the Rows in this example) 

4. What Do You See? The formula and the 
answer are correct. However, the 
formatting--8:30:00 AM--is confusing.

Keep going...
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Exam 77-427 Microsoft Excel 2013 EXPERT
2. Apply Custom Formats and Layouts 
2.1 Apply Custom Data Formats: Create Custom Formats (Number, Time, Date)

Home->Number->Number Format

Format the Time
5. Try it: Format the Time
Select Column L.
Go to Home->Number->Number Format.
(the little arrow in the bottom right corner)

Go to the Number Tab.
Select the Custom Category.
Choose: h:mm

6. What Do You See? The Duration will be 
formatted as Hours and Minutes.

Save Your Spreadsheet.
Very good. 
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Exam 77-427 Microsoft Excel 2013 EXPERT
3. Create Advanced Formulas 
3.4 Create Scenarios: Use Financial Functions

Home->Font->Bold

Financial Functions
Microsoft Excel has a robust library of Financial
Functions. Let's say that our little company, 
Charlotte's Website, needs a car. How would you 
calculate the car payments? 
Here are the steps. 

1. Before You Begin: Enter the Labels
Open a new, blank spreadsheet.
Select Cell A1 and type: Present Value
Select Cell A2 and type: Number of Payments
Select Cell A3 and type: Interest Rate
Select Cell A4 and type: Payment

If these are labels, and they are, they should be 
selected and formatted BOLD.

Keep going...
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Exam 77-420 Microsoft Excel 2013 
2. Create Cells and Ranges 
2.2 Format Cells and Ranges: Apply Number Formats

Home->Number->Number Format

Enter and Format the Data
2. Try it: Enter the Data
Select Cell B1 and type: 20000
Go to Home->Number->Number Format.
Select Accounting.
This is the Present Value of the car. (Pv)

Select Cell B2 and type: 36
This is the number of payment periods. (Nper)

Select Cell B3 and type: .04
Go to Home->Number->Number Format.
Select Percent Style.
This is the Interest Rate for the loan. (Rate)

Keep going...
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Exam 77-428 Microsoft Excel 2013 EXPERT
3. Create Advanced Formulas 
3.4 Create Scenarios: Use Financial Functions

Formulas-> Function Library-> Financial-> PMT

Financial Function: PMT
3. Try it: Use a Financial Function
Select Cell B4.
Go to Formulas->Function Library.
Go to Financial. Click on PMT.

When you see the Function Arguments:
Edit the Rate: B3/12
Edit the Nper: B2
Edit the Pv: B1
Keep going, please...

Memo to Self: The Yearly Rate is divided by 
12 to get the Monthly Rate
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Exam 77-428 Microsoft Excel 2013 EXPERT
3. Create Advanced Formulas 
3.4 Create Scenarios: Use Financial Functions

Formulas->Function Library->Financial->PMT

PMT Arguments
4. What Do You See? In the example on this 
page, the payment on a $20,000 car would be 
$590.48 per month for 36 months.

What Else Do You See? A payment is a 
negative number: that means money is taken 
away from your bank account. 

Very well, that was a simple example of a 
financial formula. Microsoft Excel has many 
formulas for calculating the value of 
investments, Tbills, price, rate and yield.

OK, Save your work. 
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Summary
The purpose of the exercise was to use 
formulas, formulas, formulas. The lesson 
began with formulas that worked with 
TEXT: formatting text, combining text, and 
manipulating text. 

We also looked at formulas that work with 
DATE and TIME.

The last pages demonstrated a very simple 
FINANCIAL formula.

Allez Allez in Free.
You done good. You get the cookie.
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Lesson 2: Piggy Goes to Market
Before You Begin: Download the sample file:
Brown Bag Sales Data 2013.xlsx

Try This: Do the following steps
1. Open the sample: Brown Bag Sales Data 2013.xlsx
2. Select Column E: Sort by Date. 
3. Select Cell H1 and enter the label: UPPER
4. Select Cell H2 and create a Text Function that references 
Cell B2 and formats the Text as UPPER.
5. AutoFill the TEXT Function from H2:H69
6. Select Cell I1 and enter the label: CONCATENATE
7. Select Cell I2 and create a Text Function that combines 
Cell B2 and Cell D2.
Hint: You can use Row 2 to add the following ": "
8. AutoFill the TEXT Function from I2:I69. 
9. Save this as YOUR NAME Piggy Practice.

Practice Activities
4. Which of the following are text functions?
(Select all correct answers)
a. Upper
b. Substitute
c. Concatenate
d. Sum
Tip: Intermediate Excel, page 60-68

5. Excel can calculate the number of workdays 
between two given dates.
a. True
b. False
Tip: Intermediate Excel, page 72
6. Excel can calculate the amount of time 
elapsed.
a. True
b. False
Tip: Intermediate Excel, page 75

7. Which is the correct command for calculating 
payments on a car?
a. Formulas-> Calculate-> Car Payment
b. Formulas-> Financial-> Car Payment
c. Formulas->Function Library Financial-> PMT
Tip: Intermediate Excel, page 79

1. Which of the following are Paste 
Special Options? 
(Select all correct answers.)
a. Values
b. Formulas
c. Formats
d. Paste All
Tip: Intermediate Excel, page 58

2. What does the Concatenate command 
do?
a. Combines the values of the selected 
cells
b. Concentrates and compresses the 
data
c. Filters the data
Tip: Intermediate Excel, page 62

3. Which command changes the 
formatting so each word starts with an 
upper case letter?
a. Upper
b. Change Case
c. Proper
d. Sentence Case
Tip: Intermediate Excel, p 65

Test Yourself
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